diff setup.py @ 1935:1128feb54180

core: removed pyfeed and xe dependencies: pyfeed and xe where still used only for date format handling, and there is already dateutil which is a dependency of Wokkel. Furthermore pyfeed and xe are still not on pypi, causing troubles for installation with pip
author Goffi <goffi@goffi.org>
date Sun, 17 Apr 2016 17:08:12 +0200
parents 6a8b26754f0d
children 14a33c2b1b2a
line wrap: on
line diff
--- a/setup.py	Sun Apr 17 14:45:26 2016 +0200
+++ b/setup.py	Sun Apr 17 17:08:12 2016 +0200
@@ -303,7 +303,6 @@
                   ],
       scripts=['frontends/src/jp/jp', 'frontends/src/primitivus/primitivus', ],
       zip_safe=False,
-      dependency_links=['http://home.avvanta.com/%7Esteveha/pyfeed-0.7.4.tar.gz', 'http://home.avvanta.com/%7Esteveha/xe-0.7.4.tar.gz'],
-      install_requires=['twisted >= 15.2.0', 'wokkel >= 0.7.1', 'progressbar', 'urwid >= 1.2.0', 'urwid-satext >= 0.4.0', 'pyfeed', 'xe', 'mutagen', 'pillow', 'lxml >= 3.1.0', 'pyxdg', 'markdown', 'html2text', 'pycrypto >= 2.6.1', 'python-potr', 'PyOpenSSL'],
+      install_requires=['twisted >= 15.2.0', 'wokkel >= 0.7.1', 'progressbar', 'urwid >= 1.2.0', 'urwid-satext >= 0.4.0', 'mutagen', 'pillow', 'lxml >= 3.1.0', 'pyxdg', 'markdown', 'html2text', 'pycrypto >= 2.6.1', 'python-potr', 'PyOpenSSL'],
       cmdclass={'install': CustomInstall},
       )