diff pyproject.toml @ 4278:240d8b7ad906

component Conferences: implementation of SFU component to make multi-party A/V conferences: This component wrap `Galène` SFU and translate its signaling to XMPP Jingle in both direction. rel 445
author Goffi <goffi@goffi.org>
date Fri, 05 Jul 2024 17:18:37 +0200
parents 8acf46ed7f36
children 6a70fcd93a7a
line wrap: on
line diff
--- a/pyproject.toml	Fri Jul 05 17:18:37 2024 +0200
+++ b/pyproject.toml	Fri Jul 05 17:18:37 2024 +0200
@@ -43,7 +43,7 @@
     "pydantic ~= 2.4",
     "pygments < 3",
     "pygobject ~= 3.48",
-    "pyopenssl >= 23.2.0",
+    "pyopenssl ~= 24.1",
     "python-dateutil >= 2.8.1, < 3",
     # currently disabled due to incompatibility, OTR feature may be removed in
     # the close future
@@ -90,11 +90,16 @@
 remote-control = [
     "cbor2"
 ]
+conferences = [
+    "autobahn ~= 23.6"
+]
+
 all = [
     "libervia-backend[SVG]",
     "libervia-backend[GUI]",
     "libervia-backend[TUI]",
-    "libervia-backend[remote-control]"
+    "libervia-backend[remote-control]",
+    "libervia-backend[conferences]"
 ]
 
 [project.scripts]