diff setup.py @ 3160:330a5f1d9eea

core (memory/crypto): replaced `PyCrypto` by `cryptography`: `PyCrypto` is unmaintained for years but was used in SàT for password hashing. This patch fixes that by replacing `PyCrypto` by the reference `cryptography` module which is well maintained. The behaviour stays the same (except that previously async `hash`, `encrypt` and `decrypt` methods are now synchronous, as they are quick and using a deferToThread may actually be more resource intensive than using blocking methods). It is planed to improve `memory.crypto` by using more up-to-date cryptography/hashing algorithms in the future. PyCrypto is no more a dependency of SàT
author Goffi <goffi@goffi.org>
date Sun, 09 Feb 2020 23:50:26 +0100
parents 9d0df638c8b4
children f300d78f08f3
line wrap: on
line diff
--- a/setup.py	Sun Feb 09 23:50:21 2020 +0100
+++ b/setup.py	Sun Feb 09 23:50:26 2020 +0100
@@ -35,7 +35,6 @@
     'netifaces',
     'pillow',
     'progressbar2',
-    'pycrypto >= 2.6.1',
     'cryptography',
     'pygments',
     'pygobject',