diff setup.py @ 2571:4aca060075b7

setup: version is now set in SAT/VERSION, sat is not imported anymore in setup
author Goffi <goffi@goffi.org>
date Thu, 05 Apr 2018 10:41:08 +0200
parents ecb14a6036ae
children 7e7f4e344a96
line wrap: on
line diff
--- a/setup.py	Wed Apr 04 22:09:20 2018 +0200
+++ b/setup.py	Thu Apr 05 10:41:08 2018 +0200
@@ -19,7 +19,6 @@
 # along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
 from setuptools import setup, find_packages
-from sat.core.constants import Const as C
 import os
 import sys
 
@@ -55,15 +54,17 @@
 
 DBUS_DIR = 'dbus-1/services'
 DBUS_FILE = 'misc/org.goffi.SAT.service'
+with open('sat/VERSION') as f:
+    VERSION = f.read().strip()
 
 
 setup(name=NAME,
-      version=C.APP_VERSION,
+      version=VERSION,
       description=u'Salut à Toi multipurpose and multi frontend XMPP client',
       long_description=u'Salut à Toi (SàT) is a XMPP client based on a daemon/frontend architecture. Its multi frontend (desktop, web, console interface, CLI, etc) and multipurpose (instant messaging, microblogging, games, file sharing, etc).',
       author='Association « Salut à Toi »',
       author_email='contact@goffi.org',
-      url=C.APP_URL,
+      url='https://salut-a-toi.org',
       classifiers=['Development Status :: 3 - Alpha',
                    'Environment :: Console',
                    'Framework :: Twisted',
@@ -78,5 +79,6 @@
       scripts=['sat_frontends/jp/jp', 'sat_frontends/primitivus/primitivus', 'bin/sat'],
       zip_safe=False,
       install_requires=install_requires,
+      package_data={'sat': ['VERSION']},
       python_requires='~=2.7',
       )