diff setup.py @ 227:533507bb4e32

distutils wix installation
author Goffi <goffi@goffi.org>
date Wed, 05 Jan 2011 18:46:26 +0100
parents fd9b7834d98a
children b25cbec73c1e
line wrap: on
line diff
--- a/setup.py	Wed Jan 05 02:39:35 2011 +0100
+++ b/setup.py	Wed Jan 05 18:46:26 2011 +0100
@@ -71,13 +71,16 @@
       package_dir = {'sat':'src', 'sat_frontends':'frontends/src'},
       packages=['sat','sat.tools','sat.bridge', 'sat.plugins',
                 'sat_frontends', 'sat_frontends.bridge', 'sat_frontends.quick_frontend',
-                'sat_frontends.primitivus'],
-      package_data = {'sat': ['sat.tac','sat.sh']},
+                'sat_frontends.primitivus', 'sat_frontends.wix'],
+      package_data = {'sat': ['sat.tac','sat.sh'],
+                      'sat_frontends': ['wix/COPYING','wix/images/*png','wix/images/cards/*','wix/images/crystal/*']},
       data_files=[(os.path.join(sys.prefix,'share/locale/fr/LC_MESSAGES'), ['i18n/fr/LC_MESSAGES/sat.mo']),
                   (os.path.join(sys.prefix,'share/locale/fr/LC_MESSAGES'), ['frontends/i18n/fr/LC_MESSAGES/sat_frontend.mo']),
                   (os.path.join(sys.prefix,'share/locale/fr/LC_MESSAGES'), ['frontends/src/jp/i18n/fr/LC_MESSAGES/jp.mo']),
-                  ('share/doc/%s' % NAME, ['CHANGELOG', 'COPYING', 'INSTALL', 'README', 'README4TRANSLATORS'])],
-      scripts=['frontends/src/jp/jp', 'frontends/src/primitivus/primitivus'],
+                  ('share/doc/%s' % NAME, ['CHANGELOG', 'COPYING', 'INSTALL', 'README', 'README4TRANSLATORS']),
+                  ('share/doc/%s/misc' % NAME, ['frontends/src/wix/images/split_card.sh']),
+                  ],
+      scripts=['frontends/src/jp/jp', 'frontends/src/primitivus/primitivus', 'frontends/src/wix/wix'],
       cmdclass=dict(install=custom_install),
       )