diff setup.py @ 3539:60d3861e5996

bridge (dbus): use Tx DBus for backend part of D-Bus bridge: Due to recent SQLAlchemy integration, Libervia is now using AsyncIO loop exclusively as main loop, thus GLib's one can't be used anymore (event if it could be in a separate thread). Furthermore Python-DBus is known to have design flaws mentioned even in the official documentation. Tx DBus is now used to replace Python-DBus, but only for the backend for now, as it will need some work on the frontend before we can get completely rid of it.
author Goffi <goffi@goffi.org>
date Thu, 03 Jun 2021 15:21:43 +0200
parents f9a5b810f14d
children 813595f88612
line wrap: on
line diff
--- a/setup.py	Thu Jun 03 15:21:43 2021 +0200
+++ b/setup.py	Thu Jun 03 15:21:43 2021 +0200
@@ -54,6 +54,7 @@
     'pyyaml',
     'sqlalchemy >= 1.4',
     'aiosqlite',
+    'txdbus'
 ]
 
 extras_require = {