diff setup.py @ 3582:71516731d0aa

core (memory/sqla): database migration using Alembic: Alembic database migration tool, which is the recommended one for SQLAlchemy has been integrated. When a database is created, it will be used to stamp to current (head) revision, otherwise, DB will be checked to see if it needs to be updated, and upgrade will be triggered if necessary.
author Goffi <goffi@goffi.org>
date Fri, 25 Jun 2021 17:55:23 +0200
parents 8dd5e1bac9c3
children 6559c0f847d4
line wrap: on
line diff
--- a/setup.py	Fri Jun 25 10:17:34 2021 +0200
+++ b/setup.py	Fri Jun 25 17:55:23 2021 +0200
@@ -55,8 +55,9 @@
     'omemo-backend-signal < 0.3',
     'pyyaml < 5.5.0',
     'sqlalchemy >= 1.4',
+    'alembic',
     'aiosqlite',
-    'txdbus'
+    'txdbus',
 ]
 
 extras_require = {
@@ -140,6 +141,6 @@
     use_scm_version=sat_dev_version if is_dev_version else False,
     install_requires=install_requires,
     extras_require=extras_require,
-    package_data={"sat": ["VERSION"]},
+    package_data={"sat": ["VERSION", "memory/migration/alembic.ini"]},
     python_requires=">=3.7",
-)
\ No newline at end of file
+)