diff setup.py @ 3911:8289ac1b34f4

plugin XEP-0384: Fully reworked to adjust to the reworked python-omemo: - support for both (modern) OMEMO under the `urn:xmpp:omemo:2` namespace and (legacy) OMEMO under the `eu.siacs.conversations.axolotl` namespace - maintains one identity across both versions of OMEMO - migrates data from the old plugin - includes more features for protocol stability - uses SCE for modern OMEMO - fully type-checked, linted and format-checked - added type hints to various pieces of backend code used by the plugin - added stubs for some Twisted APIs used by the plugin under stubs/ (use `export MYPYPATH=stubs/` before running mypy) - core (xmpp): enabled `send` trigger and made it an asyncPoint fix 375
author Syndace <me@syndace.dev>
date Tue, 23 Aug 2022 21:06:24 +0200
parents 395b51452601
children cecf45416403
line wrap: on
line diff
--- a/setup.py	Thu Sep 22 12:03:12 2022 +0200
+++ b/setup.py	Tue Aug 23 21:06:24 2022 +0200
@@ -51,8 +51,9 @@
     'urwid >= 1.2.0, < 3',
     'urwid-satext == 0.9.*',
     'wokkel >= 18.0.0, < 19.0.0',
-    'omemo >= 0.11.0, < 0.13.0',
-    'omemo-backend-signal < 0.3',
+    'omemo >= 1.0.0, < 2',
+    'twomemo >= 1.0.0, < 2',
+    'oldmemo >= 1.0.0, < 2',
     'pyyaml < 7.0.0',
     'sqlalchemy >= 1.4',
     'alembic',