diff pyproject.toml @ 4242:8acf46ed7f36

frontends: remote control implementation: This is the frontends common part of remote control implementation. It handle the creation of WebRTC session, and management of inputs. For now the reception use freedesktop.org Desktop portal, and works mostly with Wayland based Desktop Environments. rel 436
author Goffi <goffi@goffi.org>
date Sat, 11 May 2024 13:52:43 +0200
parents b0c36f3d3e04
children
line wrap: on
line diff
--- a/pyproject.toml	Sat May 11 13:52:43 2024 +0200
+++ b/pyproject.toml	Sat May 11 13:52:43 2024 +0200
@@ -87,10 +87,14 @@
 TUI = [
     "term-image ~= 0.7.1"
 ]
+remote-control = [
+    "cbor2"
+]
 all = [
-    "libervia-backed[SVG]",
-    "libervia-backed[GUI]",
-    "libervia-backed[TUI]",
+    "libervia-backend[SVG]",
+    "libervia-backend[GUI]",
+    "libervia-backend[TUI]",
+    "libervia-backend[remote-control]"
 ]
 
 [project.scripts]
@@ -114,6 +118,7 @@
 [tool.hatch.envs.default]
 # we need system-package for GPG
 system-packages = true
+features = ["all"]
 
 [tool.hatch.envs.dev]
 dependencies = [