diff pyproject.toml @ 4210:9218d4331bb2

cli (call): `tui` output implementation: - Moved original UI to a separated class, and use if with the `simple` output - By default, best output is automatically selected. For now `gui` is selected if possible, and `simple` is used as fallback. - The new `tui` output can be used to have the videos directly embedded in the terminal, either with real videos for compatible terminal emulators, or with Unicode blocks. - Text contrôls are used for both `simple` and `tui` outputs - several options can be used with `--oo` (will be documented in next commit). rel 428
author Goffi <goffi@goffi.org>
date Fri, 16 Feb 2024 18:46:06 +0100
parents 4af030d4d3d8
children d28ad04049c7
line wrap: on
line diff
--- a/pyproject.toml	Fri Feb 16 18:46:02 2024 +0100
+++ b/pyproject.toml	Fri Feb 16 18:46:06 2024 +0100
@@ -80,6 +80,17 @@
 SVG = [
     "CairoSVG",
 ]
+GUI = [
+    "PyQt6"
+]
+TUI = [
+    "term-image ~= 0.7.1"
+]
+all = [
+    "libervia-backed[SVG]",
+    "libervia-backed[GUI]",
+    "libervia-backed[TUI]",
+]
 
 [project.scripts]
 jp = "libervia.cli.base:LiberviaCli.run"