diff setup.py @ 1115:b56374a1f6d6

misc: daemon mode refactoring: - there is no more daemon mode disctinction between local and installed version - sat is launched as daemon by default, use "sat fg" to launch it foreground
author Goffi <goffi@goffi.org>
date Wed, 20 Aug 2014 23:45:21 +0200
parents 8e15eeb3cfc3
children e89bd3a26c86
line wrap: on
line diff
--- a/setup.py	Wed Aug 20 23:42:58 2014 +0200
+++ b/setup.py	Wed Aug 20 23:45:21 2014 +0200
@@ -65,9 +65,7 @@
         run_dir = os.path.dirname(self.sh_script_path)
         with open(self.sh_script_path, 'r') as sh_file:
             for ori_line in sh_file:
-                if ori_line.startswith('DAEMON='):
-                    dest_line = 'DAEMON=""\n'  # we want to launch sat as a daemon
-                elif ori_line.startswith('TAP_PATH='):
+                if ori_line.startswith('TAP_PATH='):
                     dest_line = 'TAP_PATH="%s/"\n' % run_dir
                 elif ori_line.startswith('PYTHON='):
                     dest_line = 'PYTHON="%s"\n' % sys.executable