diff setup.py @ 2576:cb7bf936d8e8

setup, tools(utils): fixed versioning in setup and getRepositoryData
author Goffi <goffi@goffi.org>
date Fri, 06 Apr 2018 16:47:40 +0200
parents fbcdb761981c
children c180ca699e72
line wrap: on
line diff
--- a/setup.py	Fri Apr 06 15:41:26 2018 +0200
+++ b/setup.py	Fri Apr 06 16:47:40 2018 +0200
@@ -62,13 +62,10 @@
 def sat_dev_version():
     """Use mercurial data to compute version"""
     def version_scheme(version):
-        return VERSION
+        return VERSION.replace('D', '.dev0')
 
     def local_scheme(version):
-        # XXX: setuptools_scm seems buggy and the '+' and the '_' are replaced by '-'
-        #      breaking the local version identifier scheme
-        #      cf. https://github.com/pypa/setuptools_scm/issues/237
-        return "+{rev}_{distance}".format(
+        return "+{rev}.{distance}".format(
             rev=version.node[1:],
             distance=version.distance)