diff setup.py @ 3089:e75024e41f81

plugin upload, XEP-0363: code modernisation + preparation for extension: - use of async/await syntax - fileUpload's options are now serialised, allowing non string values - (XEP-0363) Slot is now a dataclass, so it can be modified by other plugins - (XEP-0363) Moved SSL related code to the new tools.web module - (XEP-0363) added `XEP-0363_upload_size` and `XEP-0363_upload` trigger points - a Deferred is not used anymore for `progress_id`, the value is directly returned
author Goffi <goffi@goffi.org>
date Fri, 20 Dec 2019 12:28:04 +0100
parents c048fc192739
children 4f8bdf50593f
line wrap: on
line diff
--- a/setup.py	Fri Dec 20 12:28:04 2019 +0100
+++ b/setup.py	Fri Dec 20 12:28:04 2019 +0100
@@ -45,6 +45,7 @@
     'sat_tmp >= 0.7.0a4',
     'shortuuid',
     'twisted[tls] >= 19.7.0',
+    'treq',
     'urwid >= 1.2.0',
     'urwid-satext >= 0.7.0a2',
     'wokkel >= 0.7.1',