diff setup.py @ 3259:f300d78f08f3

core: image convertion + SVG support: /!\ new optional dependency: CairoSVG (with installed `[SVG]` extra) - new `convert` method in `tools.image` to save an image in an other format, with support for SVG (when CairoSVG is available) - new `imageConvert` method is available for frontends
author Goffi <goffi@goffi.org>
date Sun, 19 Apr 2020 16:53:44 +0200
parents 330a5f1d9eea
children a3639d6d9643
line wrap: on
line diff
--- a/setup.py	Sun Apr 19 16:40:34 2020 +0200
+++ b/setup.py	Sun Apr 19 16:53:44 2020 +0200
@@ -53,6 +53,10 @@
     'omemo-backend-signal',
 ]
 
+extras_require = {
+    "SVG": ["CairoSVG"],
+}
+
 DBUS_DIR = 'dbus-1/services'
 DBUS_FILE = 'misc/org.salutatoi.SAT.service'
 with open(os.path.join(NAME, 'VERSION')) as f: