diff setup.py @ 3040:fee60f17ebac

jp: jp asyncio port: /!\ this commit is huge. Jp is temporarily not working with `dbus` bridge /!\ This patch implements the port of jp to asyncio, so it is now correctly using the bridge asynchronously, and it can be used with bridges like `pb`. This also simplify the code, notably for things which were previously implemented with many callbacks (like pagination with RSM). During the process, some behaviours have been modified/fixed, in jp and backends, check diff for details.
author Goffi <goffi@goffi.org>
date Wed, 25 Sep 2019 08:56:41 +0200
parents 3338c6a634f5
children 691283719bb2
line wrap: on
line diff
--- a/setup.py	Wed Sep 25 08:53:38 2019 +0200
+++ b/setup.py	Wed Sep 25 08:56:41 2019 +0200
@@ -87,7 +87,6 @@
     url="https://salut-a-toi.org",
     classifiers=[
         "Programming Language :: Python :: 3 :: Only",
-        "Programming Language :: Python :: 3.6",
         "Programming Language :: Python :: 3.7",
         "Development Status :: 5 - Production/Stable",
         "Environment :: Console",
@@ -110,5 +109,5 @@
     use_scm_version=sat_dev_version if is_dev_version else False,
     install_requires=install_requires,
     package_data={"sat": ["VERSION"]},
-    python_requires=">=3.6",
+    python_requires=">=3.7",
 )