comparison buildozer.spec @ 140:8f33a7c09214

build (buildozer.spec): updated buildozer spec to build with new toolchain (and code evolution since last build)
author Goffi <goffi@goffi.org>
date Fri, 13 Apr 2018 18:58:11 +0200
parents cd99f70ea592
children c3f1529aed4a
comparison
equal deleted inserted replaced
139:b270fcc87304 140:8f33a7c09214
11 11
12 # (str) Source code where the main.py live 12 # (str) Source code where the main.py live
13 source.dir = . 13 source.dir = .
14 14
15 # (list) Source files to include (let empty to include all the files) 15 # (list) Source files to include (let empty to include all the files)
16 source.include_exts = py,png,jpg,kv,atlas,conf 16 source.include_exts = py,png,jpg,kv,atlas,conf,json,svg,ttf
17 # FIXME: check if we can do sat.conf only, without every .conf 17 # FIXME: check if we can do sat.conf only, without every .conf
18 18
19 # (list) List of inclusions using pattern matching 19 # (list) List of inclusions using pattern matching
20 #source.include_patterns = assets/*,images/*.png 20 #source.include_patterns = assets/*,images/*.png
21 source.include_patterns = media 21 source.include_patterns = media,cagou,android,bin,service
22 22
23 # (list) Source files to exclude (let empty to not exclude anything) 23 # (list) Source files to exclude (let empty to not exclude anything)
24 #source.exclude_exts = spec 24 #source.exclude_exts = spec
25 25
26 # (list) List of directory to exclude (let empty to not exclude anything) 26 # (list) List of directory to exclude (let empty to not exclude anything)
27 #source.exclude_dirs = tests, bin 27 source.exclude_dirs = env
28 28
29 # (list) List of exclusions using pattern matching 29 # (list) List of exclusions using pattern matching
30 #source.exclude_patterns = license,images/*/*.jpg 30 source.exclude_patterns =
31 31
32 # (str) Application versioning (method 1) 32 # (str) Application versioning (method 1)
33 version = 0.1 33 version = 0.1
34 34
35 # (str) Application versioning (method 2) 35 # (str) Application versioning (method 2)
36 # version.regex = __version__ = ['"](.*)['"] 36 # version.regex = __version__ = ['"](.*)['"]
37 # version.filename = %(source.dir)s/main.py 37 # version.filename = %(source.dir)s/main.py
38 38
39 # (list) Application requirements 39 # (list) Application requirements
40 # comma seperated e.g. requirements = sqlite3,kivy 40 # comma seperated e.g. requirements = sqlite3,kivy
41 requirements = kivy, sqlite3, twisted, wokkel, pil, lxml, pyxdg, markdown, html2text, python-dateutil, pycrypto, pyopenssl, plyer, potr 41 requirements = hostpython2, kivy, sqlite3, pyopenssl, automat, attr, twisted, wokkel, sat, sat_tmp, pil, lxml, pyxdg, markdown, html2text, python-dateutil, pycrypto, plyer, android, python-potr, shortuuid, cryptography
42 # below are requirements for dev
43 # requirements = hostpython2, kivy, urwid, sqlite3, pyopenssl, automat, attr, twisted, wokkel, pudb, hg+http://10.0.0.1:8000#egg=sat, sat_tmp, pil, lxml, pyxdg, markdown, html2text, python-dateutil, pycrypto, plyer, android, python-potr, shortuuid, cryptography, automat
44
42 45
43 # (str) Custom source folders for requirements 46 # (str) Custom source folders for requirements
44 # Sets custom source for any requirements with recipes 47 # Sets custom source for any requirements with recipes
45 # requirements.source.kivy = ../../kivy 48 # requirements.source.kivy = ../../kivy
46 49
47 # (list) Garden requirements 50 # (list) Garden requirements
48 #garden_requirements = 51 garden_requirements = contextmenu
49 52
50 # (str) Presplash of the application 53 # (str) Presplash of the application
51 presplash.filename = %(source.dir)s/media/icons/muchoslava/png/cagou_profil_bleu_512.png 54 presplash.filename = %(source.dir)s/media/icons/muchoslava/png/cagou_profil_bleu_512.png
52 55
53 # (str) Icon of the application 56 # (str) Icon of the application
56 # (str) Supported orientation (one of landscape, portrait or all) 59 # (str) Supported orientation (one of landscape, portrait or all)
57 orientation = portrait 60 orientation = portrait
58 61
59 # (list) List of service to declare 62 # (list) List of service to declare
60 #services = NAME:ENTRYPOINT_TO_PY,NAME2:ENTRYPOINT2_TO_PY 63 #services = NAME:ENTRYPOINT_TO_PY,NAME2:ENTRYPOINT2_TO_PY
64 services = backend:backend/main.py
61 65
62 # 66 #
63 # OSX Specific 67 # OSX Specific
64 # 68 #
65 69
100 # (str) ANT directory (if empty, it will be automatically downloaded.) 104 # (str) ANT directory (if empty, it will be automatically downloaded.)
101 #android.ant_path = 105 #android.ant_path =
102 106
103 # (str) python-for-android git clone directory (if empty, it will be automatically cloned from github) 107 # (str) python-for-android git clone directory (if empty, it will be automatically cloned from github)
104 # we use our own p4a and mount in root dir on docker image 108 # we use our own p4a and mount in root dir on docker image
105 android.p4a_dir = /python-for-android-old 109 # android.p4a_dir = /python-for-android-old
106 110
107 # (str) The directory in which python-for-android should look for your own build recipes (if any) 111 # (str) The directory in which python-for-android should look for your own build recipes (if any)
108 #p4a.local_recipes = 112 #p4a.local_recipes =
109 113
110 # (list) python-for-android whitelist 114 # (list) python-for-android whitelist
184 188
185 189
186 [buildozer] 190 [buildozer]
187 191
188 # (int) Log level (0 = error only, 1 = info, 2 = debug (with command output)) 192 # (int) Log level (0 = error only, 1 = info, 2 = debug (with command output))
189 log_level = 1 193 log_level = 2
190 194
191 # (int) Display warning if buildozer is run as root (0 = False, 1 = True) 195 # (int) Display warning if buildozer is run as root (0 = False, 1 = True)
192 warn_on_root = 1 196 warn_on_root = 1
193 197
194 # (str) Path to build artifact storage, absolute or relative to spec file 198 # (str) Path to build artifact storage, absolute or relative to spec file
195 # build_dir = ./.buildozer 199 # build_dir = ./.buildozer
200 build_dir = /build/buildozer-cagou
196 201
197 # (str) Path to build output (i.e. .apk, .ipa) storage 202 # (str) Path to build output (i.e. .apk, .ipa) storage
198 # bin_dir = ./bin 203 # bin_dir = ./bin
199 204
200 # ----------------------------------------------------------------------------- 205 # -----------------------------------------------------------------------------