diff pyproject.toml @ 0:9754c1d6f4f4 draft default tip

Libervia Desktop initial commit
author Goffi <goffi@goffi.org>
date Fri, 12 Jul 2024 14:13:36 +0200
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Fri Jul 12 14:13:36 2024 +0200
@@ -0,0 +1,55 @@
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[project]
+name = "libervia-desktop"
+dynamic = ["version"]
+description = 'Desktop frontend (Qt version) for Libervia.'
+# readme = "README.md"
+license = "AGPL-3.0-or-later"
+requires-python = ">=3.10"
+keywords = [
+    "XMPP",
+    "desktop",
+    "Qt",
+    "chat",
+    "instant_messaging",
+    "file_sharing"
+]
+authors = [
+    { name = "Libervia Dev Team", email = "contact@goffi.org" },
+]
+classifiers = [
+  "Development Status :: 3 - Alpha",
+    "Environment :: X11 Applications",
+    "Environment :: X11 Applications :: Qt",
+    "Framework :: Twisted",
+    "Intended Audience :: End Users/Desktop",
+    "Operating System :: POSIX :: Linux",
+    "Topic :: Communications :: Chat",
+    "Topic :: Internet :: XMPP",
+]
+dependencies = [
+    "pyqt6 ~= 6.7.0",
+    "qasync ~= 0.27.1"
+    # "libervia-backend == 0.9.*",
+]
+
+[project.scripts]
+libervia-desktop = "libervia.desktop:run"
+
+
+[tool.hatch.build.targets.sdist]
+    include = [
+      "*.ui",
+    ]
+
+[project.urls]
+Homepage = "https://libervia.org"
+
+[tool.hatch.build.targets.wheel]
+packages = ["libervia"]
+
+[tool.hatch.version]
+path = "libervia/desktop/__init__.py"