diff setup.py @ 155:5191ba7c4df8

Work towards first release 0.5.0. - Add licensing information (MIT) - Improve installation instructions. - Use new plugins framework in twisted.
author Ralph Meijer <ralphm@ik.nu>
date Mon, 21 Aug 2006 16:05:35 +0000
parents
children 0c9001bc7f58
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Mon Aug 21 16:05:35 2006 +0000
@@ -0,0 +1,20 @@
+#!/usr/bin/env python
+
+# Copyright (c) 2003-2006 Ralph Meijer
+# See LICENSE for details.
+
+from distutils.core import setup
+
+setup(name='idavoll',
+      version='0.5.0',
+      description='Jabber Publish-Subscribe Service Component',
+      author='Ralph Meijer',
+      author_email='ralphm@ik.nu',
+      url='http://idavoll.ik.nu/',
+      license='MIT',
+      packages=[
+          'idavoll',
+          'twisted.plugins',
+      ],
+      package_data={'twisted.plugins': ['twisted/plugins/idavoll.py']}
+)