diff setup.py @ 190:6e6c89eca9db

Make sure optional PostgreSQL connect parameters are passed as None, require wokkel and uuid in setup.py. Release 0.7.2.
author Ralph Meijer <ralphm@ik.nu>
date Sat, 17 May 2008 18:30:39 +0000
parents c61034369463
children 8ab16e319bb8
line wrap: on
line diff
--- a/setup.py	Tue Apr 22 13:15:53 2008 +0000
+++ b/setup.py	Sat May 17 18:30:39 2008 +0000
@@ -1,12 +1,18 @@
 #!/usr/bin/env python
 
-# Copyright (c) 2003-2006 Ralph Meijer
+# Copyright (c) 2003-2008 Ralph Meijer
 # See LICENSE for details.
 
+import sys
 from setuptools import setup
 
+install_requires = ['wokkel >= 0.3.1']
+
+if sys.version_info < (2, 5):
+    install_requires.append('uuid')
+
 setup(name='idavoll',
-      version='0.7.0',
+      version='0.7.2',
       description='Jabber Publish-Subscribe Service Component',
       author='Ralph Meijer',
       author_email='ralphm@ik.nu',
@@ -20,4 +26,5 @@
       package_data={'twisted.plugins': ['twisted/plugins/idavoll.py',
                                         'twisted/plugins/idavoll_http.py']},
       zip_safe=False,
+      install_requires=install_requires,
 )