diff setup.py @ 414:ccb2a22ea0fc

Python 3 port: /!\ Python 3.6+ is now needed to use SàT Pubsub /!\ instability may occur and features may not be working anymore, this will improve with time The same procedure as in backend has been applied (check backend commit ab2696e34d29 logs for details). Python minimal version has been updated in setup.py
author Goffi <goffi@goffi.org>
date Fri, 16 Aug 2019 12:53:33 +0200
parents ff17f5cd8300
children ee722faa3e93
line wrap: on
line diff
--- a/setup.py	Fri Aug 16 12:48:34 2019 +0200
+++ b/setup.py	Fri Aug 16 12:53:33 2019 +0200
@@ -52,8 +52,8 @@
 
 setup(name=NAME,
       version=VERSION,
-      description=u'XMPP Publish-Subscribe Service Component, build for the need of '
-                  u'the « Salut à Toi » project',
+      description='XMPP Publish-Subscribe Service Component, build for the need of '
+                  'the « Salut à Toi » project',
       author='Association « Salut à Toi »',
       author_email='goffi@goffi.org',
       url='https://salut-a-toi.org',
@@ -72,5 +72,5 @@
       use_scm_version=sat_dev_version if is_dev_version else False,
       install_requires=install_requires,
       package_data={'sat_pubsub': ['VERSION']},
-      python_requires='~=2.7',
+      python_requires='>=3.6',
       )