diff setup.py @ 1519:01b8d68edd70

version: use standard Python's `dev0` instead of Libervia specific `D` for dev version
author Goffi <goffi@goffi.org>
date Tue, 06 Jun 2023 17:40:16 +0200
parents eb00d593801d
children
line wrap: on
line diff
--- a/setup.py	Fri Jun 02 16:49:28 2023 +0200
+++ b/setup.py	Tue Jun 06 17:40:16 2023 +0200
@@ -42,14 +42,14 @@
 
 with open(os.path.join(DIR_NAME, "VERSION")) as v:
     VERSION = v.read().strip()
-is_dev_version = VERSION.endswith("D")
+is_dev_version = VERSION.endswith(".dev0")
 
 
 def libervia_dev_version():
     """Use mercurial data to compute version"""
 
     def version_scheme(version):
-        return VERSION.replace("D", ".dev0")
+        return VERSION
 
     def local_scheme(version):
         return "+{rev}.{distance}".format(rev=version.node[1:], distance=version.distance)