diff setup.py @ 1272:3a3f3bccd65b

server: Libervia server is now launched with a Python script, following backend change
author Goffi <goffi@goffi.org>
date Mon, 25 May 2020 15:51:07 +0200
parents 6d49fae517ba
children dbd573b0bc9c
line wrap: on
line diff
--- a/setup.py	Tue May 19 18:33:18 2020 +0200
+++ b/setup.py	Mon May 25 15:51:07 2020 +0200
@@ -84,7 +84,11 @@
         (os.path.join("share", NAME, root), [os.path.join(root, f) for f in files])
         for root, dirs, files in os.walk("themes")
     ],
-    scripts=["bin/libervia"],
+    entry_points={
+        "console_scripts": [
+            "libervia = libervia.server.launcher:Launcher.run",
+            ],
+        },
     zip_safe=False,
     setup_requires=["setuptools_scm"] if is_dev_version else [],
     use_scm_version=libervia_dev_version if is_dev_version else False,