diff setup.py @ 1253:6d49fae517ba

pages: browser metadata + root `_browser`: - the `_browser` directory can now be put in root of a site `pages` directory, it will then include modules for the whole website - in `_browser` directories (notably the root one), a `browser_meta.json` file can be put to specify settings for a browser engine - pathlib.Path is now used LiberviaRootResource.site_path - introduced some type hints - task_brython copy modules in root `_browser` to build_path root. - minimal python version is now 3.7 due to type hints
author Goffi <goffi@goffi.org>
date Wed, 29 Apr 2020 17:34:53 +0200
parents 560d381943d8
children 3a3f3bccd65b
line wrap: on
line diff
--- a/setup.py	Wed Apr 29 15:00:54 2020 +0200
+++ b/setup.py	Wed Apr 29 17:34:53 2020 +0200
@@ -90,5 +90,5 @@
     use_scm_version=libervia_dev_version if is_dev_version else False,
     install_requires=install_requires,
     package_data={"libervia": ["VERSION"]},
-    python_requires=">=3.6",
+    python_requires=">=3.7",
 )