diff pyproject.toml @ 1522:a44f77559279

installation: moved from `setup.py` to `pyproject.toml`: - following backend change, installation is now using `pyproject.toml`, and legacy `setup.py` as well as other legacy files have been deleted/updated. - [hatch](https://hatch.pypa.io) is now used as main building tool. However, thanks to the use of standards, other tools can be used too. - `VERSION` file has been deleted, in favor or using directly `__version__`, in `libervia/web/__init__.py`. Version can be updated directly from Hatch - update .hgignore - several dependencies version bump, with code update to adapt to changes.
author Goffi <goffi@goffi.org>
date Wed, 07 Jun 2023 15:28:10 +0200
parents
children 311febeae2d5
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Wed Jun 07 15:28:10 2023 +0200
@@ -0,0 +1,67 @@
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[project]
+name = "libervia-web"
+dynamic = ["version"]
+description = "Web frontend for Libervia, a feature-rich XMPP client"
+readme = "README.md"
+license = "AGPL-3.0-or-later"
+requires-python = ">=3.7"
+authors = [
+    { name = "Libervia Dev Team", email = "contact@goffi.org" },
+]
+classifiers = [
+    "Development Status :: 5 - Production/Stable",
+    "Environment :: Web Environment",
+    "Framework :: Twisted",
+    "Operating System :: POSIX :: Linux",
+    "Topic :: Communications :: Chat",
+]
+dependencies = [
+    "autobahn >= 23.6.1",
+    "brython >= 3.10",
+    "jinja2 >= 3.1.2",
+    # use during dev mode to have current version of backend
+    "libervia-backend @ {root:uri}/../libervia-backend",
+    "libervia-templates @ {root:uri}/../libervia-backend",
+    "pyopenssl >= 23.2.0",
+    "shortuuid ~= 1.0.11",
+    "twisted[tls] >= 22.10",
+    "zope.interface >= 5",
+]
+keywords = [
+    "XMPP",
+    "web",
+    "brython",
+    "chat",
+    "instant_messaging",
+    "blogging",
+    "photo albums",
+    "file sharing",
+    "events"
+]
+
+[project.scripts]
+libervia-web = "libervia.web.server.launcher:Launcher.run"
+
+[project.urls]
+Homepage = "https://www.libervia.org"
+
+[tool.hatch.build.targets.wheel]
+packages = ["libervia"]
+
+[tool.hatch.envs.default]
+# we need system-package for GPG
+system-packages = true
+
+[tool.hatch.metadata]
+allow-direct-references = true
+
+[tool.hatch.version]
+path = "libervia/web/__init__.py"
+
+[tool.hatch.build.targets.wheel.shared-data]
+COPYING = "share/doc/libervia-web/COPYING"
+"README.md" = "share/doc/libervia-web/README.md"