diff setup.py @ 1216:b2d067339de3

python 3 port: /!\ Python 3.6+ is now needed to use libervia /!\ instability may occur and features may not be working anymore, this will improve with time /!\ TxJSONRPC dependency has been removed The same procedure as in backend has been applied (check backend commit ab2696e34d29 logs for details). Removed now deprecated code (Pyjamas compiled browser part, legacy blog, JSON RPC related code). Adapted code to work without `html` and `themes` dirs.
author Goffi <goffi@goffi.org>
date Tue, 13 Aug 2019 19:12:31 +0200
parents ece192e6b4db
children b2a9da7708f6
line wrap: on
line diff
--- a/setup.py	Tue Aug 13 09:39:33 2019 +0200
+++ b/setup.py	Tue Aug 13 19:12:31 2019 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python2
+#!/usr/bin/env python3
 # -*- coding: utf-8 -*-
 
 # Libervia: a Salut à Toi frontend
@@ -24,17 +24,16 @@
 NAME = "libervia"
 
 install_requires = [
-    "sat>=0.7.0",
+    "sat>=0.8.0.dev0",
     "sat-templates",
     "twisted",
-    "txJSON-RPC==0.3.1",
     "zope.interface",
     "pyopenssl",
     "jinja2>=2.9",
     "shortuuid",
     "autobahn",
 ]
-long_description = u"""\
+long_description = """\
 Libervia is a web frontend for Salut à Toi (SàT), a multi-frontends and multi-purposes XMPP client.
 It features chat, blog, forums, events, tickets, merge requests, file sharing, photo albums, etc.
 It is also a decentralized, XMPP based web framework.
@@ -60,7 +59,7 @@
 setup(
     name=NAME,
     version=VERSION,
-    description=u"Web frontend for Salut à Toi",
+    description="Web frontend for Salut à Toi",
     long_description=long_description,
     author="Association « Salut à Toi »",
     author_email="contact@goffi.org",
@@ -79,7 +78,7 @@
     data_files=[(os.path.join("share", "doc", NAME), ["COPYING", "README", "INSTALL"])]
     + [
         (os.path.join("share", NAME, root), [os.path.join(root, f) for f in files])
-        for root, dirs, files in os.walk(u"themes")
+        for root, dirs, files in os.walk("themes")
     ],
     scripts=["bin/libervia"],
     zip_safe=False,