diff setup.py @ 602:be3fd3874c3a frontends_multi_profiles

add very basic test system accessible from <root_url>/test, to be improved: - if you don't get any AssertError pop-up, everything is fine - TODO: nicely display the results in HTML output
author souliane <souliane@mailoo.org>
date Sat, 07 Feb 2015 19:24:38 +0100
parents 0a06cf833f5a
children 9877607c719a
line wrap: on
line diff
--- a/setup.py	Sat Feb 07 19:22:45 2015 +0100
+++ b/setup.py	Sat Feb 07 19:24:38 2015 +0100
@@ -119,7 +119,10 @@
         os.symlink(os.path.dirname(sat.__file__), os.path.join(tmp_dir,"sat")) # FIXME: only work on unixes
         os.symlink(os.path.dirname(sat_frontends.__file__), os.path.join(tmp_dir,"sat_frontends")) # FIXME: only work on unixes
         os.symlink(os.path.dirname(libervia.__file__), os.path.join(tmp_dir,"libervia")) # FIXME: only work on unixes
-        result = subprocess.call(['pyjsbuild', 'libervia_main', '-d', '--no-compile-inplace', '-I', tmp_dir, '-o', self.pyjamas_output_dir])
+        for module in ('libervia_main', 'libervia_test'):
+            result = subprocess.call(['pyjsbuild', module, '-d', '--no-compile-inplace', '-I', tmp_dir, '-o', self.pyjamas_output_dir])
+            if result != 0:
+                continue
         shutil.rmtree(tmp_dir)
         os.chdir(cwd)
         return result