diff mod_pubsub_summary/mod_pubsub_summary.lua @ 4609:fcfe691d6322

mod_pubsub_summary: Use pre-escaped UTF-8 sequence for compat This silences a warning about using the non-existent global 'utf8' each time this line was hit. The utf8 library was introduced in Lua 5.3, so the warning would appear with 5.1 and 5.2.
author Kim Alvefur <zash@zash.se>
date Wed, 30 Jun 2021 15:53:49 +0200
parents 98864dffb231
children
line wrap: on
line diff
--- a/mod_pubsub_summary/mod_pubsub_summary.lua	Wed Jun 30 14:48:59 2021 +0200
+++ b/mod_pubsub_summary/mod_pubsub_summary.lua	Wed Jun 30 15:53:49 2021 +0200
@@ -28,7 +28,7 @@
 				lt = "<";
 				gt = ">";
 				amp = "&";
-				nbsp = utf8 and utf8.char(0xa0) or " ";
+				nbsp = "\194\160"; -- U+00A0
 			});
 	end
 	local summary;