view mod_auth_ldap.wiki @ 428:4e1a0785c0e4

Edited wiki page mod_firewall through web user interface.
author florob@babelmonkeys.de
date Mon, 17 Feb 2014 00:11:00 +0000
parents 7e5c6a70af1e
children 042161223488
line wrap: on
line source

#summary LDAP authentication module
#labels Stage-Alpha,Type-Auth

_*Note:* A modified version of this module is available, but is not yet committed here. The plan is to merge them, for more info see [http://groups.google.com/group/prosody-dev/browse_thread/thread/282e876116ae4177/906121492495ad35#906121492495ad35 this thread]._

= Introduction =

This is a Prosody authentication plugin which uses LDAP as the backend.

= Configuration =

Copy the module to the prosody modules/plugins directory.

In Prosody's configuration file, under the desired host section, add:
{{{
	authentication = "ldap"
}}}

LDAP options are:
|| *Name*        || *Description*                                      || *Default value*  ||
|| ldap_server   || space-separated list of hostnames or IPs           || "localhost"      ||
|| ldap_rootdn   || the distinguished name to auth against             || "" (anonymous)   ||
|| ldap_password || the password                                       || ""               ||
|| ldap_filter   || search filter, with $user substituded for username || "(uid=$user)"    ||
|| ldap_scope    || search scope. other values: "base" and "subtree"   || "onelevel"       ||
|| ldap_tls      || Use TLS to connect to LDAP? (can be true or false) || false            ||
|| ldap_base     || LDAP base directory which stores user accounts     || this is required ||
|| ldap_mode     || How to validate passwords.  Other option is "bind" || "getpasswd"      ||

= Modes =

The "getpasswd" mode requires plain text access to passwords in LDAP and
feeds them into Prosodys authentication system.  This enables more secure
authentication mechanisms but does not work for all deployments.

The "bind" performs an LDAP bind, does not require plain text access to
passwords but limits you to the PLAIN authentication mechanism.

= Compatibility =

|| 0.8 and above || should work ||