diff setup.py @ 70:922b2f0efa60

install (setup.py): better classifiers + minimal python version is 3.6
author Goffi <goffi@goffi.org>
date Mon, 18 Nov 2019 19:14:24 +0100
parents 0721b6254c9e
children 29b383e14ebf
line wrap: on
line diff
--- a/setup.py	Tue Aug 13 18:58:11 2019 +0200
+++ b/setup.py	Mon Nov 18 19:14:24 2019 +0100
@@ -36,12 +36,18 @@
     author='Association « Salut à Toi »',
     author_email='contact@salut-a-toi.org',
     url='https://salut-a-toi.org',
-    classifiers=['Development Status :: 3 - Alpha',
-                 'License :: OSI Approved :: GNU Affero General Public License v3 or later (AGPLv3+)',
-                 'Operating System :: POSIX :: Linux',
-                 'Topic :: Communications :: Chat'],
+    classifiers=[
+        "Programming Language :: Python :: 3 :: Only",
+        "Programming Language :: Python :: 3.7",
+        "Development Status :: 5 - Production/Stable",
+        "License :: OSI Approved :: GNU Affero General Public License v3 "
+        "or later (AGPLv3+)",
+        "Operating System :: POSIX :: Linux",
+        "Topic :: Communications :: Chat",
+    ],
     install_requires=['wokkel >= 0.7.1'],
     packages=['sat_tmp', 'sat_tmp.wokkel', 'sat_tmp.wokkel.test'],
     data_files=[(os.path.join('share/doc', NAME),
                 ['README', 'COPYING'])],
+    python_requires=">=3.6",
 )