diff setup.py @ 45:c8cb4e867897

made proper package + installation
author Arnaud Joset <info@agayon.be>
date Thu, 02 Nov 2017 22:50:59 +0100
parents
children 0a2d12d4ffd6
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Thu Nov 02 22:50:59 2017 +0100
@@ -0,0 +1,54 @@
+#!/usr/bin/env python2
+# -*- coding: utf-8 -*-
+
+# SàT tmp: repository to store temporarily patches to third party software
+# until they are merged upstream
+# Copyright (C) 2017  Arnaud Joset (info@agayon.be)
+# Copyright (C) 2009-2017  Jérôme Poisson (goffi@goffi.org)
+# Copyright (C) 2013-2016 Adrien Cossa (souliane@mailoo.org)
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+import sys
+from setuptools import setup, find_packages
+
+
+includefiles = ['COPYING','README']
+include_modules = []
+
+base = None
+NAME = 'sat_tmp'
+is_wheel = 'bdist_wheel' in sys.argv
+
+excluded = []
+
+def create_package_list(base_package):
+    return ([base_package] + [base_package + '.' + pkg for pkg in find_packages(base_package)])
+
+setup_info = dict(
+    name=NAME,
+    version='0.7',
+    author='Association « Salut à Toi »',
+    author_email='contact@salut-a-toi.org',
+    url='https://salut-a-toi.org',
+    classifiers=['Development Status :: 3 - Alpha',
+                 'License :: OSI Approved :: GNU Affero General Public License v3 or later (AGPLv3+)',
+                 'Operating System :: POSIX :: Linux',
+                 'Topic :: Communications :: Chat'],
+    install_requires=['wokkel >= 0.7.1'],
+    packages=create_package_list('sat_tmp'),
+    zip_safe=True,
+)
+
+setup(**setup_info)