diff setup.py @ 130:406c310e52b5 0.7.0a1

0.7.0a1 release
author Goffi <goffi@goffi.org>
date Wed, 04 Jul 2018 07:45:36 +0200
parents 33cb9a05ff84
children 331546daef20
line wrap: on
line diff
--- a/setup.py	Fri Jul 14 08:31:10 2017 +0200
+++ b/setup.py	Wed Jul 04 07:45:36 2018 +0200
@@ -2,6 +2,7 @@
 # -*- coding: utf-8 -*-
 
 from ez_setup import use_setuptools
+
 use_setuptools()
 
 from setuptools import setup
@@ -9,21 +10,34 @@
 from os import path
 from glob import glob
 
-name = 'urwid_satext'
+name = "urwid_satext"
 
-setup(name=name,
-      version='0.6.1',
-      description=u'SàT extension widgets for Urwid',
-      long_description=u'Urwid SàT extension widgets is a set of widgets for the console user interface library Urwid (http://excess.org/urwid/). This library, originaly made for the SàT project, was eventually separated so other softwares can use it. Widgets provided include password text box, tab container, dialogs, file chooser etc. Feel free to go to the project page for more informations.',
-      author='Goffi (Jérôme Poisson)',
-      author_email='goffi@goffi.org',
-      url='http://wiki.goffi.org/wiki/Urwid-satext',
-      classifiers=['Environment :: Console',
-                   'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
-                   'Intended Audience :: Developers'],
-      packages=['urwid_satext'],
-      data_files=[(path.join(sys.prefix,'share/locale/fr/LC_MESSAGES'), ['i18n/fr/LC_MESSAGES/urwid_satext.mo']),
-                  ('share/doc/%s/examples' % name, glob("examples/*.py")),
-                  ('share/doc/%s' % name, ['COPYING','COPYING.LESSER','README', "CHANGELOG"])],
-      install_requires=['urwid >= 1.2.0']
-     )
+setup(
+    name=name,
+    version="0.7.0a1",
+    description=u"SàT extension widgets for Urwid",
+    long_description=(u"Urwid SàT extension widgets is a set of widgets for the console "
+                      u"user interface library Urwid (http://excess.org/urwid/). This "
+                      u"library, originaly made for the SàT project, was eventually "
+                      u"separated so other softwares can use it. Widgets provided "
+                      u"include password text box, tab container, dialogs, file chooser "
+                      u"etc. Feel free to go to the project page for more informations."),
+    author="Goffi (Jérôme Poisson)",
+    author_email="goffi@goffi.org",
+    url="http://wiki.goffi.org/wiki/Urwid-satext",
+    classifiers=[
+        "Environment :: Console",
+        "License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)",
+        "Intended Audience :: Developers",
+    ],
+    packages=["urwid_satext"],
+    data_files=[
+        (
+            path.join(sys.prefix, "share/locale/fr/LC_MESSAGES"),
+            ["i18n/fr/LC_MESSAGES/urwid_satext.mo"],
+        ),
+        ("share/doc/%s/examples" % name, glob("examples/*.py")),
+        ("share/doc/%s" % name, ["COPYING", "COPYING.LESSER", "README", "CHANGELOG"]),
+    ],
+    install_requires=["urwid >= 1.2.0"],
+)