diff setup.py @ 34:875ff127b2dd

- i18n management: gettext integration + french translation - added misc files to distribution
author Goffi <goffi@goffi.org>
date Tue, 28 Dec 2010 21:48:01 +0100
parents 42cb54666fc2
children 5a8e2200ddc0
line wrap: on
line diff
--- a/setup.py	Tue Dec 28 21:46:25 2010 +0100
+++ b/setup.py	Tue Dec 28 21:48:01 2010 +0100
@@ -2,12 +2,19 @@
 # -*- coding: utf-8 -*-
 
 from distutils.core import setup
+import sys
+from os import path
 
-setup(name='urwid-satext',
+name = 'urwid_satext'
+
+setup(name=name,
       version='0.1.0',
       description=u'SàT extension widgets for Urwid',
       author='Goffi (Jérôme Poisson)',
       author_email='goffi@goffi.org',
       url='http://wiki.goffi.org/wiki/Urwid-satext',
       packages=['urwid_satext'],
+      data_files=[(path.join(sys.prefix,'share/locale/fr/LC_MESSAGES'), ['i18n/fr/LC_MESSAGES/urwid_satext.mo']),
+                  ('share/doc/%s/examples' % name, ["examples/file_dialog.py"]),
+                  ('share/doc/%s' % name, ['COPYING','COPYING.LESSER','README'])]
      )