diff setup.py @ 39:8cc5970039f3 0.1.0

distribute is now used with distutils, added urwid requirement
author Goffi <goffi@goffi.org>
date Tue, 11 Jan 2011 15:32:14 +0100
parents 67d312aee431
children 39c1448badd7
line wrap: on
line diff
--- a/setup.py	Tue Dec 28 22:38:20 2010 +0100
+++ b/setup.py	Tue Jan 11 15:32:14 2011 +0100
@@ -1,7 +1,10 @@
 #!/usr/bin/env python
 # -*- coding: utf-8 -*-
 
-from distutils.core import setup
+from distribute_setup import use_setuptools
+use_setuptools()
+
+from setuptools import setup
 import sys
 from os import path
 from glob import glob
@@ -21,5 +24,6 @@
       packages=['urwid_satext'],
       data_files=[(path.join(sys.prefix,'share/locale/fr/LC_MESSAGES'), ['i18n/fr/LC_MESSAGES/urwid_satext.mo']),
                   ('share/doc/%s/examples' % name, glob("examples/*.py")),
-                  ('share/doc/%s' % name, ['COPYING','COPYING.LESSER','README'])]
+                  ('share/doc/%s' % name, ['COPYING','COPYING.LESSER','README'])],
+      install_requires = ['urwid']
      )