diff setup.py @ 145:d505d9ee792e v0.8.0b1

v0.8.0b1 release
author Goffi <goffi@goffi.org>
date Fri, 18 Jun 2021 13:19:44 +0200
parents 144bdf877d21
children 3ff24fbf03c1
line wrap: on
line diff
--- a/setup.py	Sun Oct 27 18:55:47 2019 +0100
+++ b/setup.py	Fri Jun 18 13:19:44 2021 +0200
@@ -1,5 +1,4 @@
-#!/usr/bin/env python
-# -*- coding: utf-8 -*-
+#!/usr/bin/env python3
 
 from setuptools import setup
 from glob import glob
@@ -8,18 +7,23 @@
 
 setup(
     name=name,
-    version="0.8.0.dev0",
+    version="0.8.0b1",
     description="SàT extension widgets for Urwid",
-    long_description=("Urwid SàT extension widgets is a set of widgets for the console "
-                      "user interface library Urwid (http://excess.org/urwid/). This "
-                      "library, originaly made for the SàT project, was eventually "
-                      "separated so other softwares can use it. Widgets provided "
-                      "include password text box, tab container, dialogs, file chooser "
-                      "etc. Feel free to go to the project page for more informations."),
+    long_description=(
+        "Urwid SàT extension widgets is a set of widgets for the console "
+        "user interface library Urwid (http://excess.org/urwid/). This "
+        'library, originaly made for the Libervia (formerly "SàT") project, was '
+        "eventually separated so other softwares can use it. Widgets provided "
+        "include password text box, tab container, dialogs, file chooser "
+        "etc. Feel free to go to the project page for more informations."),
     author="Goffi (Jérôme Poisson)",
     author_email="goffi@goffi.org",
-    url="http://wiki.goffi.org/wiki/Urwid-satext",
+    url="https://wiki.goffi.org/w/index.php/Urwid-satext",
     classifiers=[
+        "Programming Language :: Python :: 3 :: Only",
+        "Programming Language :: Python :: 3.7",
+        "Programming Language :: Python :: 3.8",
+        "Programming Language :: Python :: 3.9",
         "Environment :: Console",
         "License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)",
         "Intended Audience :: Developers",