changeset 1496:b0d02dd25c2a default tip @

install: requirements.txt update
author Goffi <goffi@goffi.org>
date Sat, 14 May 2022 22:45:25 +0200
parents 081b4f8a63d8
children
files requirements.txt
diffstat 1 files changed, 51 insertions(+), 40 deletions(-) [+]
line wrap: on
line diff
--- a/requirements.txt	Sat May 14 22:45:11 2022 +0200
+++ b/requirements.txt	Sat May 14 22:45:25 2022 +0200
@@ -1,70 +1,81 @@
-attrs==20.3.0
+aiosqlite==0.17.0
+alembic==1.7.7
+attrs==21.4.0
 autobahn==21.3.1
 Automat==20.2.0
-Babel==2.9.0
-brython==3.9.1
-cairocffi==1.2.0
+Babel==2.10.1
+brython==3.9.6
+cairocffi==1.3.0
 CairoSVG==2.5.2
-certifi==2020.12.5
-cffi==1.14.5
-chardet==4.0.0
+certifi==2021.10.8
+cffi==1.15.0
+charset-normalizer==2.0.12
 constantly==15.1.0
-cryptography==3.4.6
-cssselect2==0.4.1
-dbus-python==1.2.16
+cryptography==3.4.8
+cssselect2==0.6.0
+dbus-python==1.2.18
 defusedxml==0.7.1
 DoubleRatchet==0.7.0
+greenlet==1.1.2
 html2text==2020.1.16
 hyperlink==21.0.0
-idna==2.10
+idna==3.3
 incremental==21.3.0
-Jinja2==2.11.3
+Jinja2==3.0.3
 langid==1.1.6
-lxml==4.6.2
-Markdown==3.3.4
-MarkupSafe==1.1.1
+lxml==4.8.0
+Mako==1.2.0
+Markdown==3.3.7
+MarkupSafe==2.1.1
 miniupnpc==2.0.2
 mutagen==1.45.1
-netifaces==0.10.9
-numpy==1.20.1
+netifaces==0.11.0
+numpy==1.22.3
 OMEMO==0.12.0
-omemo-backend-signal==0.2.6
-Pillow==8.1.2
-progressbar2==3.53.1
-protobuf==3.15.6
+omemo-backend-signal==0.2.7
+packaging==21.3
+Pillow==9.1.0
+progressbar2==3.53.3
+protobuf==3.20.1
 pyasn1==0.4.8
 pyasn1-modules==0.2.8
-pycairo==1.20.0
-pycparser==2.20
+pycairo==1.21.0
+pycparser==2.21
 pycrypto==2.6.1
-Pygments==2.8.1
+Pygments==2.12.0
 PyGObject==3.40.0
-PyNaCl==1.4.0
+PyNaCl==1.5.0
 pyOpenSSL==20.0.1
-python-dateutil==2.8.1
+pyparsing==3.0.9
+python-dateutil==2.8.2
 python-potr==1.0.2
-python-utils==2.5.6
-pytz==2021.1
+python-utils==3.2.2
+pytz==2022.1
 pyxdg==0.27
 PyYAML==5.4.1
-requests==2.25.1
-service-identity==18.1.0
-shortuuid==1.0.1
-six==1.15.0
-tinycss2==1.1.0
-treq==21.1.0
+requests==2.27.1
+service-identity==21.1.0
+setuptools-scm==6.4.2
+shortuuid==1.0.9
+six==1.16.0
+SQLAlchemy==1.4.36
+tinycss2==1.1.1
+tomli==2.0.1
+treq==21.5.0
 Twisted==21.2.0
-txaio==21.2.1
-urllib3==1.26.4
+txaio==22.2.1
+txdbus==1.1.2
+typing_extensions==4.2.0
+urllib3==1.26.9
 urwid==2.1.2
-urwid-satext==0.7.0
+urwid-satext==0.8.0
 webencodings==0.5.1
 wokkel==18.0.0
 X3DH==0.5.9
 XEdDSA==0.4.7
-zope.interface==5.2.0
+zope.interface==5.4.0
 
-sat-templates @ hg+https://repos.goffi.org/sat_templates
+libervia-templates @ hg+https://repos.goffi.org/libervia-templates
 sat-tmp @ hg+https://repos.goffi.org/sat_tmp
-sat @ hg+https://repos.goffi.org/sat
+libervia-backend @ hg+https://repos.goffi.org/libervia-backend
 -e .